CVE-2021-43666

NameCVE-2021-43666
DescriptionA Denial of Service vulnerability exists in mbed TLS 3.0.0 and earlier in the mbedtls_pkcs12_derivation function when an input password's length is 0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3249-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)buster2.16.0-1vulnerable
buster (security)2.16.9-0~deb10u1fixed
bullseye2.16.9-0.1vulnerable
bookworm2.28.3-1fixed
trixie2.28.7-1fixed
sid2.28.7-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssourcebuster2.16.9-0~deb10u1DLA-3249-1
mbedtlssource(unstable)2.28.0-1

Notes

[bullseye] - mbedtls <no-dsa> (Minor issue)
https://github.com/ARMmbed/mbedtls/issues/5136
Backport 2.16: https://github.com/ARMmbed/mbedtls/pull/5311

Search for package or bug name: Reporting problems