CVE-2021-43808

NameCVE-2021-43808
DescriptionLaravel is a web application framework. Laravel prior to versions 8.75.0, 7.30.6, and 6.20.42 contain a possible cross-site scripting (XSS) vulnerability in the Blade templating engine. A broken HTML element may be clicked and the user taken to another location in their browser due to XSS. This is due to the user being able to guess the parent placeholder SHA-1 hash by trying common names of sections. If the parent template contains an exploitable HTML structure an XSS vulnerability can be exposed. This vulnerability has been patched in versions 8.75.0, 7.30.6, and 6.20.42 by determining the parent placeholder at runtime and using a random hash that is unique to each request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1001333

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-laravel-framework (PTS)bullseye6.20.14+dfsg-2+deb11u1fixed
sid6.20.14+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-laravel-frameworksourcebullseye6.20.14+dfsg-2+deb11u1
php-laravel-frameworksource(unstable)6.20.14+dfsg-31001333

Notes

https://github.com/laravel/framework/security/advisories/GHSA-66hf-2p6w-jqfw
https://github.com/laravel/framework/commit/b8174169b1807f36de1837751599e2828ceddb9b (v6.20.42)

Search for package or bug name: Reporting problems