CVE-2021-44038

NameCVE-2021-44038
DescriptionAn issue was discovered in Quagga through 1.2.4. Unsafe chown/chmod operations in the suggested spec file allow users (with control of the non-root-owned directory /etc/quagga) to escalate their privileges to root upon package installation or update.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)stretch (security), stretch1.1.1-3+deb9u2vulnerable
buster1.2.4-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)(unfixed)

Notes

https://bugzilla.suse.com/show_bug.cgi?id=1191890
Debian installed systemd unit files install the problematic redhat/*.service
files with the unsafe chmod/chown calls in the Debian packaging.

Search for package or bug name: Reporting problems