CVE-2021-44143

NameCVE-2021-44143
DescriptionA flaw was found in mbsync in isync 1.4.0 through 1.4.3. Due to an unchecked condition, a malicious or compromised IMAP server could use a crafted mail message that lacks headers (i.e., one that starts with an empty line) to provoke a heap overflow, which could conceivably be exploited for remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs999804

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
isync (PTS)stretch1.2.1-2fixed
buster1.3.0-2.2~deb10u1fixed
bullseye1.3.0-2.2fixed
bookworm, sid1.4.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
isyncsourcestretch(not affected)
isyncsourcebuster(not affected)
isyncsourcebullseye(not affected)
isyncsource(unstable)1.4.4-1999804

Notes

[bullseye] - isync <not-affected> (Vulnerable code introduced later)
[buster] - isync <not-affected> (Vulnerable code introduced later)
[stretch] - isync <not-affected> (Vulnerable code introduced later)
https://www.openwall.com/lists/oss-security/2021/12/03/2

Search for package or bug name: Reporting problems