CVE-2021-44269

NameCVE-2021-44269
DescriptionAn out of bounds read was found in Wavpack 5.4.0 in processing *.WAV files. This issue triggered in function WavpackPackSamples of file src/pack_utils.c, tainted variable cnt is too large, that makes pointer sptr read beyond heap bound.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wavpack (PTS)stretch5.0.0-2+deb9u2vulnerable
stretch (security)5.0.0-2+deb9u3vulnerable
buster5.1.0-6+deb10u1vulnerable
bookworm, sid, bullseye5.4.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wavpacksource(unstable)(unfixed)unimportant

Notes

https://github.com/dbry/WavPack/issues/110
Fixed by: https://github.com/dbry/WavPack/commit/773f9d0803c6888ae7d5391878d7337f24216f4a
Negligible security impact; only impacts the CLI program

Search for package or bug name: Reporting problems