CVE-2021-4435

NameCVE-2021-4435
DescriptionAn untrusted search path vulnerability was found in Yarn. When a victim runs certain Yarn commands in a directory with attacker-controlled content, malicious commands could be executed in unexpected ways.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-yarnpkg (PTS)buster1.13.0-1+deb10u1vulnerable
bullseye1.22.10+~cs22.25.14-3vulnerable
bookworm1.22.19+~cs24.27.18-2+deb12u1fixed
sid, trixie4.0.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-yarnpkgsource(unstable)1.22.19+~cs24.27.18-1

Notes

[bullseye] - node-yarnpkg <no-dsa> (Minor issue)
[buster] - node-yarnpkg <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=2262284
Fixed by: https://github.com/yarnpkg/yarn/commit/67fcce88935e45092ffa2674c08053f1ef5268a1 (v1.22.12)
check, too few details in RHBZ#2262284

Search for package or bug name: Reporting problems