CVE-2021-44513

NameCVE-2021-44513
DescriptionInsecure creation of temporary directories in tmate-ssh-server 2.3.0 allows a local attacker to compromise the integrity of session handling.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1001225

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tmate-ssh-server (PTS)bullseye, sid2.3.0-49-g97d20249-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tmate-ssh-serversource(unstable)(unfixed)1001225

Notes

[bullseye] - tmate-ssh-server <no-dsa> (Minor issue)
Fixed by: https://github.com/tmate-io/tmate-ssh-server/commit/1c020d1f5ca462f5b150b46a027aaa1bbe3c9596
https://www.openwall.com/lists/oss-security/2021/12/06/2
https://bugzilla.suse.com/show_bug.cgi?id=1189388

Search for package or bug name: Reporting problems