CVE-2021-44540

NameCVE-2021-44540
DescriptionA vulnerability was found in Privoxy which was fixed in get_url_spec_param() by freeing memory of compiled pattern spec before bailing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2844-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
privoxy (PTS)buster3.0.28-2+deb10u2fixed
bullseye3.0.32-2+deb11u1fixed
bookworm, sid3.0.33-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
privoxysourcestretch3.0.26-3+deb9u3DLA-2844-1
privoxysourcebuster3.0.28-2+deb10u2
privoxysourcebullseye3.0.32-2+deb11u1
privoxysource(unstable)3.0.33-1

Notes

https://www.openwall.com/lists/oss-security/2021/12/09/1
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commit;h=652b4b7cb07592c0912cf938a50fcd009fa29a0a (v_3_0_33)

Search for package or bug name: Reporting problems