CVE-2021-44541

NameCVE-2021-44541
DescriptionA vulnerability was found in Privoxy which was fixed in process_encrypted_request_headers() by freeing header memory when failing to get the request destination.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
privoxy (PTS)buster3.0.28-2+deb10u2fixed
bullseye3.0.32-2+deb11u1fixed
bookworm3.0.33-4fixed
sid3.0.34-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
privoxysourcestretch(not affected)
privoxysourcebuster(not affected)
privoxysourcebullseye3.0.32-2+deb11u1
privoxysource(unstable)3.0.33-1

Notes

[buster] - privoxy <not-affected> (Vulnerable code introduced in 3.0.29)
[stretch] - privoxy <not-affected> (Vulnerable code introduced in 3.0.29)
https://www.openwall.com/lists/oss-security/2021/12/09/1
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commit;h=0509c58045b26463844188e07c5e87c74ea21044 (v_3_0_33)

Search for package or bug name: Reporting problems