CVE-2021-45085

NameCVE-2021-45085
DescriptionXSS can occur in GNOME Web (aka Epiphany) before 40.4 and 41.x before 41.1 via an about: page, as demonstrated by ephy-about:overview when a user visits an XSS payload page often enough to place that page on the Most Visited list.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3074-1, DSA-5042-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
epiphany-browser (PTS)buster3.32.1.2-3~deb10u1vulnerable
buster (security)3.32.1.2-3~deb10u2fixed
bullseye (security), bullseye3.38.2-1+deb11u3fixed
bookworm, sid43.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
epiphany-browsersourcebuster3.32.1.2-3~deb10u2DLA-3074-1
epiphany-browsersourcebullseye3.38.2-1+deb11u1DSA-5042-1
epiphany-browsersource(unstable)41.2-1

Notes

[stretch] - epiphany-browser <ignored> (WebKit browser, not covered by security support in stretch)
https://gitlab.gnome.org/GNOME/epiphany/-/issues/1612
https://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/1045

Search for package or bug name: Reporting problems