CVE-2021-45086

NameCVE-2021-45086
DescriptionXSS can occur in GNOME Web (aka Epiphany) before 40.4 and 41.x before 41.1 because a server's suggested_filename is used as the pdf_name value in PDF.js.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5042-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
epiphany-browser (PTS)buster3.32.1.2-3~deb10u1vulnerable
bullseye3.38.2-1+deb11u2fixed
bullseye (security)3.38.2-1+deb11u1fixed
bookworm42.3-1fixed
sid42.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
epiphany-browsersourcebullseye3.38.2-1+deb11u1DSA-5042-1
epiphany-browsersource(unstable)41.2-1

Notes

[buster] - epiphany-browser <no-dsa> (Minor issue)
[stretch] - epiphany-browser <ignored> (WebKit browser, not covered by security support in stretch)
https://gitlab.gnome.org/GNOME/epiphany/-/issues/1612
https://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/1045

Search for package or bug name: Reporting problems