CVE-2021-45116

NameCVE-2021-45116
DescriptionAn issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11, and 4.0 before 4.0.1. Due to leveraging the Django Template Language's variable resolution logic, the dictsort template filter was potentially vulnerable to information disclosure, or an unintended method call, if passed a suitably crafted key.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1003113

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)stretch1:1.10.7-2+deb9u9vulnerable
stretch (security)1:1.10.7-2+deb9u17vulnerable
buster, buster (security)1:1.11.29-1~deb10u1vulnerable
bullseye2:2.2.26-1~deb11u1fixed
bookworm2:3.2.13-1fixed
sid2:4.0.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosourcebullseye2:2.2.26-1~deb11u1
python-djangosource(unstable)2:3.2.11-11003113

Notes

[buster] - python-django <postponed> (Minor issue; fix in next update)
[stretch] - python-django <postponed> (Minor issue; fix in next update)
https://www.djangoproject.com/weblog/2022/jan/04/security-releases/
https://github.com/django/django/commit/c7fe895bca06daf12cc1670b56eaf72a1ef27a16 (3.2.11)
https://github.com/django/django/commit/c9f648ccfac5ab90fb2829a66da4f77e68c7f93a (2.2.26)

Search for package or bug name: Reporting problems