CVE-2021-45429

NameCVE-2021-45429
DescriptionA Buffer Overflow vulnerablity exists in VirusTotal YARA git commit: 605b2edf07ed8eb9a2c61ba22eb2e7c362f47ba7 via yr_set_configuration in yara/libyara/libyara.c, which could cause a Denial of Service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
yara (PTS)buster3.9.0-1vulnerable
bullseye4.0.5-1vulnerable
bookworm, sid4.2.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
yarasource(unstable)4.2.0-1

Notes

[bullseye] - yara <no-dsa> (Minor issue)
[buster] - yara <no-dsa> (Minor issue)
[stretch] - yara <no-dsa> (Minor issue)
https://github.com/VirusTotal/yara/issues/1616
https://github.com/VirusTotal/yara/commit/a36b497926b141624ea673111a101e9ddd7ac2eb (v4.2.0-rc1)

Search for package or bug name: Reporting problems