CVE-2021-45482

NameCVE-2021-45482
DescriptionIn WebKitGTK before 2.32.4, there is a use-after-free in WebCore::ContainerNode::firstChild, a different vulnerability than CVE-2021-30889.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4975-1, DSA-4976-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.34.6-1~deb10u1fixed
buster (security)2.36.4-1~deb10u1fixed
bullseye2.36.3-1~deb11u1fixed
bullseye (security)2.36.4-1~deb11u1fixed
bookworm, sid2.36.4-1fixed
wpewebkit (PTS)bullseye2.36.3-1~deb11u1fixed
bullseye (security)2.36.4-1~deb11u1fixed
bookworm, sid2.36.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.32.4-1~deb10u1DSA-4975-1
webkit2gtksourcebullseye2.32.4-1~deb11u1DSA-4975-1
webkit2gtksource(unstable)2.32.4-1
wpewebkitsourcebullseye2.32.4-1~deb11u1DSA-4976-1
wpewebkitsource(unstable)2.32.4-1

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)

Search for package or bug name: Reporting problems