CVE-2021-45707

NameCVE-2021-45707
DescriptionAn issue was discovered in the nix crate 0.16.0 and later before 0.20.2, 0.21.x before 0.21.2, and 0.22.x before 0.22.2 for Rust. unistd::getgrouplist has an out-of-bounds write if a user is in more than 16 /etc/groups groups.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-nix (PTS)bullseye0.19.0-1vulnerable
bookworm0.26.1-3fixed
sid, trixie0.27.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-nixsourcebuster(not affected)
rust-nixsource(unstable)0.23.0-1

Notes

[bullseye] - rust-nix <no-dsa> (Minor issue)
[buster] - rust-nix <not-affected> (Introduced in 0.16)
https://rustsec.org/advisories/RUSTSEC-2021-0119.html

Search for package or bug name: Reporting problems