CVE-2021-45908

NameCVE-2021-45908
DescriptionAn issue was discovered in gif2apng 1.9. There is a stack-based buffer overflow involving a while loop. An attacker has little influence over the data written to the stack, making it unlikely that the flow of control can be subverted.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs1002669

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gif2apng (PTS)buster, stretch1.9+srconly-2vulnerable
bookworm, sid, bullseye1.9+srconly-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gif2apngsource(unstable)(unfixed)unimportant1002669

Notes

Negligible security impact

Search for package or bug name: Reporting problems