CVE-2021-45930

NameCVE-2021-45930
DescriptionQt SVG in Qt 5.0.0 through 5.15.2 and 6.0.0 through 6.2.1 has an out-of-bounds write in QtPrivate::QCommonArrayOps<QPainterPath::Element>::growAppend (called from QPainterPath::addPath and QPathClipper::intersect).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2885-1, DLA-2895-1
Debian Bugs1002991

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)buster4:4.8.7+dfsg-18+deb10u1vulnerable
qtsvg-opensource-src (PTS)buster5.11.3-2vulnerable
bullseye5.15.2-3vulnerable
bookworm5.15.4-2fixed
sid5.15.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11sourcestretch4:4.8.7+dfsg-11+deb9u3DLA-2895-1
qt4-x11source(unstable)(unfixed)
qtsvg-opensource-srcsourcestretch5.7.1~20161021-2.1+deb9u1DLA-2885-1
qtsvg-opensource-srcsource(unstable)5.15.2-41002991

Notes

[bullseye] - qtsvg-opensource-src <no-dsa> (Minor issue)
[buster] - qtsvg-opensource-src <no-dsa> (Minor issue)
[buster] - qt4-x11 <no-dsa> (Minor issue)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=37025
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=37306
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/qt/OSV-2021-1121.yaml
https://bugreports.qt.io/browse/QTBUG-96044
https://github.com/qt/qtsvg/commit/36cfd9efb9b22b891adee9c48d30202289cfa620 (dev)
https://github.com/qt/qtsvg/commit/79bb9f51fa374106a612d17c9d98d35d807be670 (v6.2.2)
https://github.com/qt/qtsvg/commit/a3b753c2d077313fc9eb93af547051b956e383fc (v5.12.12)

Search for package or bug name: Reporting problems