CVE-2021-46052

NameCVE-2021-46052
DescriptionA Denial of Service vulnerability exists in Binaryen 104 due to an assertion abort in wasm::Tuple::validate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
binaryen (PTS)buster68-1vulnerable
bullseye99-3vulnerable
bookworm104-1vulnerable
sid105-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
binaryensource(unstable)(unfixed)unimportant

Notes

https://github.com/WebAssembly/binaryen/issues/4411
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems