CVE-2021-46340

NameCVE-2021-46340
DescriptionThere is an Assertion 'context_p->stack_top_uint8 == SCAN_STACK_TRY_STATEMENT || context_p->stack_top_uint8 == SCAN_STACK_CATCH_STATEMENT' failed at /parser/js/js-scanner.c(scanner_scan_statement_end) in JerryScript 3.0.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1004288

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iotjs (PTS)buster1.0-1fixed
bookworm, bullseye, sid1.0+715-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iotjssourcebuster(not affected)
iotjssource(unstable)(unfixed)1004288

Notes

[bullseye] - iotjs <no-dsa> (Minor issue)
[buster] - iotjs <not-affected> (Vulnerable code introduced later)
https://github.com/jerryscript-project/jerryscript/pull/4964
https://github.com/jerryscript-project/jerryscript/issues/4924

Search for package or bug name: Reporting problems