CVE-2021-46671

NameCVE-2021-46671
Descriptionoptions.c in atftp before 0.7.5 reads past the end of an array, and consequently discloses server-side /etc/group data to a remote client.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3028-1
Debian Bugs1004974

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
atftp (PTS)buster0.7.git20120829-3.2~deb10u3fixed
bullseye0.7.git20120829-3.3+deb11u2fixed
bookworm, sid0.8.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
atftpsourcestretch0.7.git20120829-3.1~deb9u3DLA-3028-1
atftpsourcebuster0.7.git20120829-3.2~deb10u3
atftpsourcebullseye0.7.git20120829-3.3+deb11u2
atftpsource(unstable)0.7.git20210915-11004974

Notes

https://sourceforge.net/p/atftp/code/ci/9cf799c40738722001552618518279e9f0ef62e5 (v0.7.5)

Search for package or bug name: Reporting problems