CVE-2021-46848

NameCVE-2021-46848
DescriptionGNU Libtasn1 before 4.19.0 has an ETYPE_OK off-by-one array size check that affects asn1_encode_simple_der.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3263-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libtasn1-6 (PTS)buster4.13-3vulnerable
buster (security)4.13-3+deb10u1fixed
bullseye4.16.0-2+deb11u1fixed
bookworm, sid4.19.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libtasn1-6sourcebuster4.13-3+deb10u1DLA-3263-1
libtasn1-6sourcebullseye4.16.0-2+deb11u1
libtasn1-6source(unstable)4.19.0-2

Notes

https://gitlab.com/gnutls/libtasn1/-/commit/44a700d2051a666235748970c2df047ff207aeb5 (v4.19.0)
https://gitlab.com/gnutls/libtasn1/-/issues/32

Search for package or bug name: Reporting problems