CVE-2021-46854

NameCVE-2021-46854
Descriptionmod_radius in ProFTPD before 1.3.7c allows memory disclosure to RADIUS servers because it copies blocks of 16 characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs993173

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
proftpd-dfsg (PTS)buster1.3.6-4+deb10u6fixed
buster (security)1.3.6-4+deb10u4vulnerable
bullseye1.3.7a+dfsg-12+deb11u2fixed
bookworm, sid1.3.7d+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
proftpd-dfsgsourcebuster1.3.6-4+deb10u6
proftpd-dfsgsourcebullseye1.3.7a+dfsg-12+deb11u1
proftpd-dfsgsource(unstable)1.3.7c+dfsg-1993173

Notes

https://github.com/proftpd/proftpd/issues/1284
https://github.com/proftpd/proftpd/pull/1285
Fixed by: https://github.com/proftpd/proftpd/commit/10a227b4d50e0a2cd2faf87926f58d865da44e43 (v1.3.8rc2)
Fixed by: https://github.com/proftpd/proftpd/commit/e7c0b6e78a81fa97ec41ea6332e5e11b864089b8 (v1.3.7c)

Search for package or bug name: Reporting problems