CVE-2021-46872

NameCVE-2021-46872
DescriptionAn issue was discovered in Nim before 1.6.2. The RST module of the Nim language stdlib, as used in NimForum and other products, permits the javascript: URI scheme and thus can lead to XSS in some applications. (Nim versions 1.6.2 and later are fixed; there may be backports of the fix to some earlier versions. NimForum 2.2.0 is fixed.)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nim (PTS)buster0.19.4-1vulnerable
bullseye1.4.6+really1.4.2-2vulnerable
bookworm, sid1.6.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nimsource(unstable)1.6.2-1

Notes

[bullseye] - nim <no-dsa> (Minor issue)
[buster] - nim <no-dsa> (Minor issue)
https://github.com/nim-lang/Nim/pull/19134
https://github.com/nim-lang/Nim/commit/9338aa24977e84a33b9a7802eaff0777fcf4d9c3

Search for package or bug name: Reporting problems