CVE-2022-0135

NameCVE-2022-0135
DescriptionAn out-of-bounds write issue was found in the VirGL virtual OpenGL renderer (virglrenderer). This flaw allows a malicious guest to create a specially crafted virgil resource and then issue a VIRTGPU_EXECBUFFER ioctl, leading to a denial of service or possible code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1009073

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
virglrenderer (PTS)buster0.7.0-2vulnerable
bullseye0.8.2-5vulnerable
bookworm0.10.1-1fixed
sid0.10.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
virglrenderersource(unstable)0.10.0-11009073

Notes

[bullseye] - virglrenderer <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=2037790
https://gitlab.freedesktop.org/virgl/virglrenderer/-/merge_requests/654
Fixed by: https://gitlab.freedesktop.org/virgl/virglrenderer/-/commit/95e581fd181b213c2ed7cdc63f2abc03eaaa77ec (0.10.0)

Search for package or bug name: Reporting problems