CVE-2022-0204

NameCVE-2022-0204
DescriptionA heap overflow vulnerability was found in bluez in versions prior to 5.63. An attacker with local network access could pass specially crafted files causing an application to halt or crash, leading to a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1003712

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bluez (PTS)buster, buster (security)5.50-1.2~deb10u2vulnerable
bullseye5.55-3.1vulnerable
bookworm, sid5.65-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bluezsource(unstable)5.64-11003712

Notes

[bullseye] - bluez <no-dsa> (Minor issue)
[buster] - bluez <no-dsa> (Minor issue)
[stretch] - bluez <no-dsa> (Minor issue)
https://github.com/bluez/bluez/security/advisories/GHSA-479m-xcq5-9g2q
Fixed by: https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/?id=591c546c536b42bef696d027f64aa22434f8c3f0 (5.63)
https://bugzilla.redhat.com/show_bug.cgi?id=2039807

Search for package or bug name: Reporting problems