CVE-2022-0318

NameCVE-2022-0318
DescriptionHeap-based Buffer Overflow in vim/vim prior to 8.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3204-1
Debian Bugs1004859

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u4fixed
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:9.0.0813-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcebuster2:8.1.0875-5+deb10u4DLA-3204-1
vimsource(unstable)2:8.2.4659-1unimportant1004859

Notes

[stretch] - vim <postponed> (Fix introduces a test regression)
https://huntr.dev/bounties/0d10ba02-b138-4e68-a284-67f781a62d08
https://github.com/vim/vim/commit/57df9e8a9f9ae1aafdde9b86b10ad907627a87dc (v8.2.4151)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems