CVE-2022-0361

NameCVE-2022-0361
DescriptionHeap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2947-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:8.2.4793-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcestretch2:8.0.0197-4+deb9u5DLA-2947-1
vimsource(unstable)2:8.2.4659-1

Notes

[bullseye] - vim <no-dsa> (Minor issue)
[buster] - vim <no-dsa> (Minor issue)
https://huntr.dev/bounties/a055618c-0311-409c-a78a-99477121965b
https://github.com/vim/vim/commit/dc5490e2cbc8c16022a23b449b48c1bd0083f366 (v8.2.4215)

Search for package or bug name: Reporting problems