CVE-2022-0392

NameCVE-2022-0392
DescriptionHeap-based Buffer Overflow in GitHub repository vim prior to 8.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:8.2.4793-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcestretch(not affected)
vimsource(unstable)2:8.2.4659-1

Notes

[bullseye] - vim <no-dsa> (Minor issue)
[buster] - vim <no-dsa> (Minor issue)
[stretch] - vim <not-affected> (vulnerable code was introduced later)
https://huntr.dev/bounties/d00a2acd-1935-4195-9d5b-4115ef6b3126
https://github.com/vim/vim/commit/806d037671e133bd28a7864248763f643967973a (v8.2.4218)

Search for package or bug name: Reporting problems