CVE-2022-0407

NameCVE-2022-0407
DescriptionHeap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2fixed
buster (security)2:8.1.0875-5+deb10u4fixed
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:9.0.0813-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcestretch(not affected)
vimsourcebuster(not affected)
vimsource(unstable)2:8.2.4659-1unimportant

Notes

[buster] - vim <not-affected> (The vulnerable code is not present)
[stretch] - vim <not-affected> (The vulnerable code is not present)
https://huntr.dev/bounties/81822bf7-aafe-4d37-b836-1255d46e572c
https://github.com/vim/vim/commit/44db8213d38c39877d2148eff6a72f4beccfb94e (v8.2.4219)
Crash in CLI tool, no security issue

Search for package or bug name: Reporting problems