CVE-2022-0543

NameCVE-2022-0543
DescriptionIt was discovered, that redis, a persistent key-value database, due to a packaging issue, is prone to a (Debian-specific) Lua sandbox escape, which could result in remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5081-1
Debian Bugs1005787

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redis (PTS)buster, buster (security)5:5.0.14-1+deb10u2fixed
bullseye (security), bullseye5:6.0.16-1+deb11u2fixed
bookworm, sid5:7.0.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redissourcestretch(not affected)
redissourcebuster5:5.0.14-1+deb10u2DSA-5081-1
redissourcebullseye5:6.0.16-1+deb11u2DSA-5081-1
redissource(unstable)5:6.0.16-21005787

Notes

[stretch] - redis <not-affected> (Lua support plus packaging issue introduced later)
https://www.ubercomp.com/posts/2022-01-20_redis_on_debian_rce

Search for package or bug name: Reporting problems