CVE-2022-0570

NameCVE-2022-0570
DescriptionHeap-based Buffer Overflow in Homebrew mruby prior to 3.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mruby (PTS)stretch1.2.0+20161228+git30d5424a-1fixed
stretch (security)1.2.0+20161228+git30d5424a-1+deb9u1fixed
buster2.0.0-1fixed
bullseye2.1.2-3fixed
bookworm, sid3.0.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mrubysource(unstable)(not affected)

Notes

- mruby <not-affected> (Vulnerable code introduced later)
https://huntr.dev/bounties/65a7632e-f95b-4836-b1a7-9cb95e5124f1
https://github.com/mruby/mruby/commit/38b164ace7d6ae1c367883a3d67d7f559783faad

Search for package or bug name: Reporting problems