CVE-2022-0577

NameCVE-2022-0577
DescriptionExposure of Sensitive Information to an Unauthorized Actor in GitHub repository scrapy/scrapy prior to 2.6.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2950-1
Debian Bugs1008234

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-scrapy (PTS)stretch1.0.3-2vulnerable
stretch (security)1.0.3-2+deb9u1fixed
buster1.5.1-1vulnerable
bullseye2.4.1-2vulnerable
bookworm, sid2.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-scrapysourcestretch1.0.3-2+deb9u1DLA-2950-1
python-scrapysource(unstable)2.6.1-11008234

Notes

[bullseye] - python-scrapy <no-dsa> (Minor issue)
[buster] - python-scrapy <no-dsa> (Minor issue)
https://github.com/advisories/GHSA-cjvr-mfj7-j4j8
https://huntr.dev/bounties/3da527b1-2348-4f69-9e88-2e11a96ac585
https://github.com/scrapy/scrapy/commit/8ce01b3b76d4634f55067d6cfdf632ec70ba304a

Search for package or bug name: Reporting problems