CVE-2022-0629

NameCVE-2022-0629
DescriptionStack-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3204-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u4fixed
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:9.0.0813-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcebuster2:8.1.0875-5+deb10u4DLA-3204-1
vimsource(unstable)2:8.2.4659-1unimportant

Notes

https://huntr.dev/bounties/95e2b0da-e480-4ee8-9324-a93a2ab0a877/
https://github.com/vim/vim/commit/34f8117dec685ace52cd9e578e2729db278163fc (v8.2.4397)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems