CVE-2022-0639

NameCVE-2022-0639
DescriptionAuthorization Bypass Through User-Controlled Key in NPM url-parse prior to 1.5.7.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3336-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-url-parse (PTS)buster1.2.0-2+deb10u1vulnerable
buster (security)1.2.0-2+deb10u2fixed
bullseye1.5.3-1+deb11u2vulnerable
bookworm1.5.10+~1.4.8-2fixed
trixie, sid1.5.10+~1.4.8-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-url-parsesourcestretch(unfixed)end-of-life
node-url-parsesourcebuster1.2.0-2+deb10u2DLA-3336-1
node-url-parsesource(unstable)1.5.7-1

Notes

[bullseye] - node-url-parse <no-dsa> (Minor issue)
[stretch] - node-url-parse <end-of-life> (Nodejs in stretch not covered by security support)
https://huntr.dev/bounties/83a6bc9a-b542-4a38-82cd-d995a1481155
https://github.com/unshiftio/url-parse/commit/ef45a1355375a8244063793a19059b4f62fc8788 (1.5.7)

Search for package or bug name: Reporting problems