CVE-2022-0686

NameCVE-2022-0686
DescriptionAuthorization Bypass Through User-Controlled Key in NPM url-parse prior to 1.5.8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-url-parse (PTS)stretch1.0.5-2+deb9u1vulnerable
buster1.2.0-2+deb10u1vulnerable
bullseye1.5.3-1vulnerable
bookworm, sid1.5.10+~1.4.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-url-parsesourcestretch(unfixed)end-of-life
node-url-parsesource(unstable)1.5.9+~1.4.8-1

Notes

[stretch] - node-url-parse <end-of-life> (Nodejs in stretch not covered by security support)
https://huntr.dev/bounties/55fd06cd-9054-4d80-83be-eb5a454be78c
https://github.com/unshiftio/url-parse/commit/d5c64791ef496ca5459ae7f2176a31ea53b127e5 (1.5.8)

Search for package or bug name: Reporting problems