CVE-2022-0998

NameCVE-2022-0998
DescriptionAn integer overflow flaw was found in the Linux kernel’s virtio device driver code in the way a user triggers the vhost_vdpa_config_validate function. This flaw allows a local user to crash or potentially escalate their privileges on the system.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)buster4.19.249-2fixed
buster (security)4.19.260-1fixed
bullseye5.10.140-1fixed
bullseye (security)5.10.136-1fixed
bookworm, sid5.19.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch(not affected)
linuxsourcebuster(not affected)
linuxsourcebullseye5.10.92-1
linuxsource(unstable)5.15.15-1unimportant

Notes

[buster] - linux <not-affected> (ulnerable code not present)
[stretch] - linux <not-affected> (ulnerable code not present)
https://git.kernel.org/linus/3ed21c1451a14d139e1ceb18f2fa70865ce3195a (5.16-rc6)
CONFIG_VHOST_VDPA not set in Debian

Search for package or bug name: Reporting problems