CVE-2022-1071

NameCVE-2022-1071
DescriptionUser after free in mrb_vm_exec in GitHub repository mruby/mruby prior to 3.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1014968

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mruby (PTS)buster2.0.0-1vulnerable
bullseye2.1.2-3vulnerable
sid3.0.0-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mrubysource(unstable)(unfixed)1014968

Notes

[bullseye] - mruby <no-dsa> (Minor issue)
[buster] - mruby <no-dsa> (Minor issue)
https://huntr.dev/bounties/6597ece9-07af-415b-809b-919ce0a17cf3
https://github.com/mruby/mruby/commit/aaa28a508903041dd7399d4159a8ace9766b022f

Search for package or bug name: Reporting problems