CVE-2022-1270

NameCVE-2022-1270
DescriptionIn GraphicsMagick, a heap buffer overflow was found when parsing MIFF.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3200-1, DSA-5288-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)buster1.4+really1.3.35-1~deb10u2vulnerable
buster (security)1.4+really1.3.35-1~deb10u3fixed
bullseye1.4+really1.3.36+hg16481-2vulnerable
bullseye (security)1.4+really1.3.36+hg16481-2+deb11u1fixed
bookworm, sid1.4+really1.3.38+hg16739-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksourcebuster1.4+really1.3.35-1~deb10u3DLA-3200-1
graphicsmagicksourcebullseye1.4+really1.3.36+hg16481-2+deb11u1DSA-5288-1
graphicsmagicksource(unstable)1.4+really1.3.38-1

Notes

https://sourceforge.net/p/graphicsmagick/bugs/664/
http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/94f4bcf448ad

Search for package or bug name: Reporting problems