CVE-2022-1381

NameCVE-2022-1381
Descriptionglobal heap buffer overflow in skip_range in GitHub repository vim/vim prior to 8.2.4763. This vulnerability is capable of crashing software, Bypass Protection Mechanism, Modify Memory, and possible remote execution
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)stretch2:8.0.0197-4+deb9u3fixed
stretch (security)2:8.0.0197-4+deb9u6fixed
buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:8.2.4793-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcestretch(not affected)
vimsource(unstable)2:8.2.4793-1

Notes

[bullseye] - vim <no-dsa> (Minor issue)
[buster] - vim <no-dsa> (Minor issue)
[stretch] - vim <not-affected> (Vulnerable code not present)
https://huntr.dev/bounties/55f9c0e8-c221-48b6-a00e-bdcaebaba4a4/
https://github.com/vim/vim/commit/f50808ed135ab973296bca515ae4029b321afe47 (v8.2.4763)

Search for package or bug name: Reporting problems