CVE-2022-1515

NameCVE-2022-1515
DescriptionA memory leak was discovered in matio 1.5.21 and earlier in Mat_VarReadNextInfo5() in mat5.c via a crafted file. This issue can potentially result in DoS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmatio (PTS)stretch1.5.9-1vulnerable
buster1.5.13-3vulnerable
bullseye1.5.19-2vulnerable
bookworm, sid1.5.23-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmatiosource(unstable)1.5.22-1

Notes

https://github.com/tbeu/matio/issues/186
Fixed by: https://github.com/tbeu/matio/commit/b53b62b756920f4c1509f4ee06427f66c3b5c9c4 (v1.5.22)

Search for package or bug name: Reporting problems