CVE-2022-1629

NameCVE-2022-1629
DescriptionBuffer Over-read in function find_next_quote in GitHub repository vim/vim prior to 8.2.4925. This vulnerabilities are capable of crashing software, Modify Memory, and possible remote execution
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)stretch2:8.0.0197-4+deb9u3vulnerable
stretch (security)2:8.0.0197-4+deb9u6vulnerable
buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:8.2.4793-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)(unfixed)unimportant

Notes

https://huntr.dev/bounties/e26d08d4-1886-41f0-9af4-f3e1bf3d52ee
https://github.com/vim/vim/commit/53a70289c2712808e6d4e88927e03cac01b470dd (v8.2.4925)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems