CVE-2022-1769

NameCVE-2022-1769
DescriptionBuffer Over-read in GitHub repository vim/vim prior to 8.2.4974.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)stretch2:8.0.0197-4+deb9u3vulnerable
stretch (security)2:8.0.0197-4+deb9u7vulnerable
buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:8.2.4793-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)(unfixed)unimportant

Notes

https://huntr.dev/bounties/522076b2-96cb-4df6-a504-e6e2f64c171c
https://github.com/vim/vim/commit/4748c4bd64610cf943a431d215bb1aad51f8d0b4 (v8.2.4974)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems