CVE-2022-1771

NameCVE-2022-1771
DescriptionUncontrolled Recursion in GitHub repository vim/vim prior to 8.2.4975.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:8.2.4793-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)(unfixed)unimportant

Notes

https://huntr.dev/bounties/faa74175-5317-4b71-a363-dfc39094ecbb
https://github.com/vim/vim/commit/51f0bfb88a3554ca2dde777d78a59880d1ee37a8 (v8.2.4975)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems