CVE-2022-1795

NameCVE-2022-1795
DescriptionUse After Free in GitHub repository gpac/gpac prior to v2.1.0-DEV.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpac (PTS)stretch0.5.2-426-gc5ad4e4+dfsg5-3+deb9u1vulnerable
buster0.5.2-426-gc5ad4e4+dfsg5-5vulnerable
bullseye (security), bullseye1.0.1+dfsg1-4+deb11u1vulnerable
bookworm, sid2.0.0+dfsg1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gpacsourcestretch(unfixed)end-of-life
gpacsource(unstable)(unfixed)

Notes

[stretch] - gpac <end-of-life> (No longer supported in LTS)
https://huntr.dev/bounties/9c312763-41a6-4fc7-827b-269eb86efcbc
https://github.com/gpac/gpac/commit/c535bad50d5812d27ee5b22b54371bddec411514

Search for package or bug name: Reporting problems