CVE-2022-2124

NameCVE-2022-2124
DescriptionBuffer Over-read in GitHub repository vim/vim prior to 8.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3053-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)stretch2:8.0.0197-4+deb9u3vulnerable
stretch (security)2:8.0.0197-4+deb9u7fixed
buster2:8.1.0875-5+deb10u2vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:8.2.4793-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcestretch2:8.0.0197-4+deb9u7DLA-3053-1
vimsource(unstable)(unfixed)

Notes

https://huntr.dev/bounties/8e9e056d-f733-4540-98b6-414bf36e0b42
https://github.com/vim/vim/commit/2f074f4685897ab7212e25931eeeb0212292829f (v8.2.5120)

Search for package or bug name: Reporting problems