CVE-2022-21694

NameCVE-2022-21694
DescriptionOnionShare is an open source tool that lets you securely and anonymously share files, host websites, and chat with friends using the Tor network. The website mode of the onionshare allows to use a hardened CSP, which will block any scripts and external resources. It is not possible to configure this CSP for individual pages and therefore the security enhancement cannot be used for websites using javascript or external resources like fonts or images.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1014966

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
onionshare (PTS)buster1.3.2-1fixed
bullseye2.2-3+deb11u1vulnerable
bookworm, sid2.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
onionsharesourcebuster(not affected)
onionsharesource(unstable)2.5-1unimportant1014966

Notes

[buster] - onionshare <not-affected> (Vulnerable code not present)
https://github.com/onionshare/onionshare/security/advisories/GHSA-h29c-wcm8-883h
https://github.com/onionshare/onionshare/issues/1389
This isn't a security vulnerability by itself

Search for package or bug name: Reporting problems