CVE-2022-21708

NameCVE-2022-21708
Descriptiongraphql-go is a GraphQL server with a focus on ease of use. In versions prior to 1.3.0 there exists a DoS vulnerability that is possible due to a bug in the library that would allow an attacker with specifically designed queries to cause stack overflow panics. Any user with access to the GraphQL handler can send these queries and cause stack overflows. This in turn could potentially compromise the ability of the server to serve data to its users. The issue has been patched in version `v1.3.0`. The only known workaround for this issue is to disable the `graphql.MaxDepth` option from your schema which is not recommended.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-github-graph-gophers-graphql-go (PTS)buster0.0~git20180609.bb97385-2vulnerable
bullseye0.0~git20180609.bb97385-2.1vulnerable
bookworm, sid1.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-github-graph-gophers-graphql-gosource(unstable)1.3.0-1

Notes

[bullseye] - golang-github-graph-gophers-graphql-go <no-dsa> (Minor issue)
[buster] - golang-github-graph-gophers-graphql-go <no-dsa> (Minor issue)
https://github.com/graph-gophers/graphql-go/commit/eae31ca73eb3473c544710955d1dbebc22605bfe (v1.3.0)
https://github.com/graph-gophers/graphql-go/security/advisories/GHSA-mh3m-8c74-74xh
https://github.com/graph-gophers/graphql-go/pull/492

Search for package or bug name: Reporting problems