CVE-2022-21712

NameCVE-2022-21712
Descriptiontwisted is an event-driven networking engine written in Python. In affected versions twisted exposes cookies and authorization headers when following cross-origin redirects. This issue is present in the `twited.web.RedirectAgent` and `twisted.web. BrowserLikeRedirectAgent` functions. Users are advised to upgrade. There are no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2927-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
twisted (PTS)stretch16.6.0-2vulnerable
stretch (security)16.6.0-2+deb9u3fixed
buster18.9.0-3vulnerable
bullseye20.3.0-7vulnerable
bookworm, sid22.4.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
twistedsourcestretch16.6.0-2+deb9u1DLA-2927-1
twistedsource(unstable)22.1.0-1

Notes

[bullseye] - twisted <no-dsa> (Minor issue)
[buster] - twisted <no-dsa> (Minor issue)
https://github.com/twisted/twisted/security/advisories/GHSA-92x2-jw7w-xvvx
https://github.com/twisted/twisted/commit/af8fe78542a6f2bf2235ccee8158d9c88d31e8e2 (twisted-22.1.0rc1)

Search for package or bug name: Reporting problems