CVE-2022-21831

NameCVE-2022-21831
DescriptionA code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing arguments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3093-1
Debian Bugs1011940

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)buster2:5.2.2.1+dfsg-1+deb10u3vulnerable
buster (security)2:5.2.2.1+dfsg-1+deb10u5fixed
bullseye2:6.0.3.7+dfsg-2vulnerable
bookworm, sid2:6.1.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssourcebuster2:5.2.2.1+dfsg-1+deb10u4DLA-3093-1
railssource(unstable)2:6.1.4.7+dfsg-11011940

Notes

https://github.com/advisories/GHSA-w749-p3v6-hccq
https://github.com/rails/rails/commit/b0b5eaf477c907819ead1808d09bfaae3eb4cc54 (v6.1.4.7)
https://github.com/rails/rails/commit/92f64fec3136baabbebac97073c5213ea055dc53 (v6.0.4.7)
https://github.com/rails/rails/commit/94e2f00d2abedbea1ef62fc775d031ffda00662c (v5.2.6.3)

Search for package or bug name: Reporting problems