CVE-2022-22589

NameCVE-2022-22589
DescriptionA validation issue was addressed with improved input sanitization. This issue is fixed in iOS 15.3 and iPadOS 15.3, watchOS 8.4, tvOS 15.3, Safari 15.3, macOS Monterey 12.2. Processing a maliciously crafted mail message may lead to running arbitrary javascript.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5083-1, DSA-5084-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1fixed
buster (security)2.36.7-1~deb10u1fixed
bullseye (security), bullseye2.36.7-1~deb11u1fixed
bookworm2.36.7-1fixed
sid2.38.0-1fixed
wpewebkit (PTS)bullseye (security), bullseye2.36.7-1~deb11u1fixed
bookworm, sid2.38.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.34.6-1~deb10u1DSA-5083-1
webkit2gtksourcebullseye2.34.6-1~deb11u1DSA-5083-1
webkit2gtksource(unstable)2.34.5-1
wpewebkitsourcebullseye2.34.6-1~deb11u1DSA-5084-1
wpewebkitsource(unstable)2.34.5-1

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
https://webkitgtk.org/security/WSA-2022-0002.html

Search for package or bug name: Reporting problems